ClickLearn in a virtual desktop

  • 28 September 2020
  • 6 replies

Doing the trial of ClickLearn and having issues creating content in a virtual environment. I’m on google and we’re using VMWare. Are there known issues creating content using a virtual desktop?


Best answer by Tobias 28 September 2020, 10:27

View original

6 replies

Userlevel 2



To use ClickLearn in a virtual environment a few prerequisites must be set:

  1. ClickLearn must be executed in the same instance as the application you like to record. Meaning that ClickLearn Studio and these application must be installed in the same VM.
  2. ClickLearn studio needs to be installed via the .MSI installer, This can be found here:
  3. Please make sure that inside the CVM the user has modify access to C:\ProgramData\ClickLearn

If you have further question please feel free to write to the ClickLearn support:

Thanks for the reply. I’ve taken care of all of the above. However, when I record in virtual desktop it doesn’t record the individual clicks and only shows the green around the whole browser screen. I’ve tried this in Chrome (with the connector extension installed), edge (version 85), and IE. All produce the same result so I’m guessing there’s a setting of some sort I need to toggle.

Userlevel 2



If you have done all the steps above please check also that the native messaging host is installed.


Please see here: 

  1. In the ClickLearn Studio you need to make sure that the Chrome Native Messaging Host is installed.

To do so just open Clicklearn Studio goto : tools – preferences – troubleshoot -  and click on install  Chrome Native Messaging Host

Thanks! I did that as well and still getting the same problem.

Userlevel 2



This is a very unusual issue and i can see that you have raised a support ticket already for this,


I have taken this request and will get in touch with you directly

Hey folks -was a solution to this issue found?  I am having much the same, however as our VMs run on a secured network the “Install Native Messaging Host” is failing.

Is there a way to manually install the host?